1) when in options (F10menu -> options), F10 brings another menu (and mess a little ESC functionality sometimes). I guess it shouldn't

2) ESC should bring options when there is nothing to cancel

3) when in options and dropdown some combobox, mouse scrolling outside that combo should still scroll the main list. When combo goes outside a screen it's "impossible" to scroll down to see all the choices it has

4) it would be nice to have "Keyboard scroll speed" option. Map scrolling is way to slow on zoom-

5) card collection - grid mode - letters are too small (1920x1200). I would suggest to enlarge card a bit on mouse over or at least on click so the text is readable

6) card collecion - grid mode - cannot select the card to play, only possible in scrolling view. Why?

7) card collection - filters are not working. Seeing all cards on "All". But any other choice show nothing or card which doesn't belong there ("Call of Valor" is in "Unit advantage" instead of dragon advantage/skill)

8) research - no tooltip or hint on how long it takes? Also it shows full bar before I start research (should show empty).

9) research suggestions - should be indicator on main screen (possibly turns left) and if possible - button to bring research on (the one on main city right click is not lucky choice IMO)

10) strategic map - there should be ability to storno unit move (by moving it back or to another tile). Saw "back" possibility, but it takes back last action, right?

11) battle card selection - missing filters?

12) dragon skill loadout - dragging skill from the list to the key should work even when skill is already assigned to another key (it should remove it). Right now, if skill is already assigned to key, you can move it from the list but you cannot assign

13) RTS mode, camera controls - I REALLY missed space/ctrl for bringing camera up and down. When I'm over battlefield and not just using WASD but want to "fly" I push middle button and expect ability to move like in other games. But since forwad + middle button goes where I look (ground usually) it brings me to close without ability to get up (scrolls are not working either with middle mouse). Space/Ctrl are most natural for me. But I need the same for dragon. To just go up/down.

14) RTS mode, tutorial - when I stopped tutorial prematurely (saw it before) and escaped, the whole game mode remained in greyscale

15) In the main menu just after start, LOAD GAME is greyed. It's needed to start new multiplayer game in order to get F10menu, where LOAD is available

That's what I've noticed in first hour. There were too many crashes in RTS thought to test it more frown Tried to describe some in that Larian debug window, hope it pack saves as well. First crash start when I've selected factory and tried to assign it under group key. Another one when just after load (for some reason always loaded in dragon form and very high zoom - close to dragon) when I want go out of dragon (needed wait like 15s before tried or instant crash). A some more frown

As for "wish". I really cannot get away the idea this game would be so glorious and unique and was meant to be played as MOBA game with "always-on" dragon, commanding buildings and general strategies. Not direct control of units. It's way to fast paced and what I was mainly do was defending.. poorly. Everything in the game just screams MOBA. Strategic map, cards, probabilities, bonuses systematics, upgrades, pace, AI.

Having blend of MOBA and I of the Dragon is my secret dream smile

Oh, forgot, Steam version 1.0.93.9727, Win7Pro64bit, i5-2500, GTX570

Last edited by Elenoe; 29/06/13 09:17 PM.