Originally Posted by Boston
I had been having the "infinite save" bug happening, and found a solution over on the Steam forum's that worked, and may for you if you're using a 32-bit system.

My System:
Windows 7 32-bit
AMD Phenom II X2 955 3.2GHz
8GB Ram (2.92GB usable)
AMD Radeon HD 6800

Steps 1 and 2 below worked for me. I didn't try them separately, but my feeling is this is a memory issue. I set memory at what the instructions say, not 3008.

I found that increasing the maximum allocated memory windows allows for applications drastically reduced the number of crashes I'm having and helps speed up the save and loading although it still slow compared to 64bit machines.

NOTE: ONLY FOR 32bit Windows versions with 4GB+ Ram installed on the machine.

STEP 1: Allocate more memory

Follow the instructions here:
(I set mine to 3008, DO NOT set any higher than 3096)

To RESET the windows to default values here is the command:
bcdedit /deletevalue IncreaseUserVa

STEP 2: Create a shortcut with administrator privileges

In Steam go to Library, right click Divinity original Sin -> Properties -> Local Files -> Browse Local Files -> Go to "Shipping" -> Right Click EoCApp.exe and create a desktop shortcut.

Then right click the new shortcut -> properties -> Compatibility -> TICK "Run this program as an administrator".

Run the game from this shortcut instead of the one steam created for you.

STEP 3: If your game is still slow or crashes:
From the game settings, remove shadows, put Antialiasing to trilinear and lower any other settings until your game runs smoothly.

Make sure you are running a command prompt AS AN ADMINISTRATOR when assigning or reseting the memory value.
For the change to take effect you need to restart your machine.
Before playing the game each time, close as many programs as possible.
Make sure to reset the values once you will no longer play the game or if you are having problems with other programs crashing. (Just note it somewhere to remember to change it in the future)

Thank you! It really helped.