I tried two solutions suggested for another game, that frequently crashed on loading attempts for many players. Saving and Loading is similar, so I tried it for Divinity too. It seems to work, but I'm not certain about which of the two helped, because I haven't played a few days until today. So maybe it's another thing but also maybe it helps:

I installed an older version of the ati video driver, 12.8 to be exact. I previously had the latest one, 14.4 and suffered from the saving bug.

Steam Users: Open the Library, right click on Divinity -> Properties -> click on Set launch settings and put -swa into the window.

For the Standalone version I don't know the precise command, -softwareaudio worked for the other game. Right click on the desktop symbol of Divinity -> Properties and put -softwareaudio at the end of the path where your exe is located.

Next time you start Divinity it's possible that in the first few minutes and especially on the first saving attempt performance is worse, but it should save correctly.

What should this command do: it forces the use of generic software audio device, if the saving issue is sound card related, it maybe helps.

I'd suggest to first try the -swa/-softwareaudio thing and if this doesn't help, try installing an older graphics card driver.

Last edited by Salumba; 01/08/14 04:08 PM.