Did the other games you tried include similarly demanding, DirectX 11 games?

Does this happen if you just leave the game sitting at the main menu, or in the options? What if you Alt-Tab out of the game, or otherwise minimize it?

Have you tried lowering the graphics settings and resolution, or switching to Windowed or Fake Fullscreen display mode, to see if that would make a difference?

Do you have Vsync enabled, or the frame rate cap set in the options? Try enabling, lowering or disabling those options.

Try verifying local files: in the Steam library, right click on Divinity Original Sin Enhanced Edition and select Properties, switch to the Local Files tab and then click on the 'Verify Integrity of Game Cache...' button.
With the GOG version, in the (optional) Galaxy client, select Divinity: Original Sin Enhanced Edition in the left column, then click on the More button, and in the Manage menu select 'Verify / Repair'.

Did you try setting the in-game volume to zero, or muting it in the Task Manager Volume control, to see if that would at least take care of the buzzing noise?
You could also try browsing to the '..\SteamApps\common\Divinity Original Sin Enhanced Edition\Data' folder (or similarly for the GOG version) and rename three 'sound' pak files. There are also 5 'voice' pak files in the '..\Data\Localization' folder.
If that doesn't help, rename the files back, so they don't get redownloaded if you verify files again.

Are you shutting down all non-essential programs (especially anti-virus) before starting the game?

Check for updated graphics drivers and Windows updates in general.