Dear Larian,

Please help me find a solution for my "mod doesn't load" problem

I have tried loading the mod I am working on in game (previously I was opening it only through engine only) and it simply and silently doesn't work.

At first I thought that some scripts are broken and I don't see any effect bun in the end I have added a simple story script that shows "MOD ENABLED" notification on "GameStarted" event... and it's not shown

Important note that in Engine everything works fine. If I do a game save while in engine and load it via game - I see my story code working.

My suspicion is that story code from my mod is not being loaded and this sucks a big time.

What I have tried:
- Loading existing save with mod enabled (and many other mods)
- Starting a new game with just this mod enabled
- Starting a new game with no mods enabled, then enabling the mod and loading the game
- I have tried loading the mod without publishing, published into local mods, moved into normal mods

None of these solutions worked.

Some mod facts:
- It is a story addon mod
- No dependencies
- Big junk of story code (4000+ lines)
- Story code is not parented to anything
- A lot of STATS entries (1000+)

Last edited by Erikem; 26/01/18 09:21 AM.