Edit: As I've been adding more lists in the comments, I'm just adding some link directly to them.
Separate posts help define what are old (and possibly fixed) and new issues. And also prevent an insanely long post.
Part 2 (Oct 8th)
Part 3 (Oct 9th)

Hey, while streaming with a friend last night, I wrote down some issues/bugs/minor things that popped up.
I've added links with timestamps to help clarify the issues.

While on the outside area of the aircraft on the first map, opening a tutorial messes up the colors of the scrolling background.

NPCs on different floors show up on the map without any indication if they are above/below, resulting in confusion.

Camera shake can really mess up any kind of targeting. Note the tooltip on the left side as it shakes between different things.

Another player listened in on a conversation I was having. This conversation ended up starting a fight. The character that friend was listening in with still showed the text bubbles during combat.
https://www.twitch.tv/videos/762487605?t=1h20m7s (Note the halfling)

After removing Us from the man in the ship by it attacking us, the man ended up sitting in the chair acting alive and well.

In locations where there is different floors, moving the camera around may result in is going up stairs correctly, but the other floor does not become visible.

There's some general issues with physics. Ragdolls freaking out, Mindflayer tentacles being weird, and demon wings being floppy.

At an unknown point, the combat in the game desynced immensely.

At some point a friend's character became unable to move at all. This might have something to do with going prone. We eventually fixed it by fully killing the character and reviving it.

Halfling animations can go very weird at time, stretching their bodies. This has happened during sneaking and certain dialogs

Sometimes the character movement doesn't match the patch and location you picked in turn based mode

The turn order gets massed up at times, incorrectly showing who goes next.

Familiars have issues following the player when climbing up ledges, and can end up getting stuck completely.
I climbed up a ledge, the spider couldn't follow. After I climbed down again, the spider was stuck in place and had to be resummoned.

Clicking on the plus icon to level up, it's possible to accidentally click the confirmation button right after.
This instantly ends the level up process. Could be fixed with a simple level up confirmation prompt.

Trying to loot items from a corpse using the right-click pickup option results in a "Out of reach!" error

Hunters Mark seems to carry over between combat. I killed something a while ago which ended combat. In new combat later on I was able to use it's re-apply option.
Not familiar with it in DnD, only googled the 5e description. Could be intentional in the game.

On multiple occasions characters ended up stuck in the dialog UI while in combat. It shows the bottom left buttons, but no exit button on the top right. This prevents them from doing anything during their turn, even skip the turn.
This was fixed by saving and reloading.

A plaque in the Druid's Cove has a weirdly large tooltip for being a single word.

When listening in on a conversation, leaving the conversation also ends it for the other player

The wares around the dwarf vendor in the Druid's Cove can be looted without counting as strealing.

During a conversation with a tiefling child in the Druid's Grove, one of the dialog options appear to be Drow specific, but the [Drow] tag did not show up in between the brackets.

On come occasions weird lights are visible during dialogs, coming from seemingly nowhere and creating harsh lighting.

Sometimes the "Journal updated" message shows up but doesn't say which jounal entry was updated.

During dialogs, items held by the characters can be sticking to hands without the hand being closed

There doesn't seem to be a way to split item stacks when trading with a vendor. I've tried using modifier keys or right clicking.

Sometimes the inventory messes up, causing multiple items to stack on a single slot. Moving an item can force fix the entire inventory.

Character positions can mess up in dialogs. Resulting in characters facing away from the person they talk to, or for them to stand inside rocks in the background.

In the Owlbear cave, it is possible for a character to climb up a wall (as intended) but end up on the ceiling once done climbing. They might later fall off causing damage and prone.
https://www.twitch.tv/videos/762487605?t=5h13m7s Notice Gale climbing up behind my character

After using mirror image and ending combat, mirror images for shield can still show up when that character gets into combat again (possibly when unseathing weapons)

An imp companion bugged out during combat, allowing it to have endless movement. This might be caused by desync that seemed to be happening around this time in the playthrough.

Cat familiar doesn't have portrait in UI

Owlbear has no portrait

Tooltip text that covers the icon on the tooltip can make it hard to heard. Examples: Shove and hide
Could be fixed some sort of text shadow

On character sheet some entries don't have a border by default. When highlighting them they end up getting a border, causing everything below it to shift a few pixels.

Not so much issues as suggestions or notes.
- The dice roll in it's current state is somewhat confusing. We eventually understood that the target number is the number after calculations. But, it seems to make more sense to show the actual target, roll the dice, and then show the number of the roll + modifiers. So, show roll + modifiers instead of target - modifiers. This feels more engaging that my numbers are strengthened instead of the target being weakened.

- Possibly give an option to turn off the chance % when doing actions. I understand that it's helpful for those that aren't familiar with DnD, hence why it should be kept as default. But it feels weird when you're used to pen and paper. Maybe (also) an option to only show bonuses such as high ground, disadvantage, threatened.

- There doesn't appear to be any way of seeing another player roll their dice when listening in on conversations. When playing DnD with friends it's fun for everyone to know the target and hoping for, and seeing, the roll result.

- Nothing seems to explain why I can't use a short rest again before taking a long rest, especially with the heal station in the tutorial level. A simple tooltip saying "Usable once(?) per day. Replenishes with a long rest" on the button would do wonders.

- The default keybind for hiding is 'c' which is typically used for the character menu, resulting in doing the wrong thing by habit. Yet 'h' doesn't seem to be bound to anything while it's the first letter of hide. Possible left over from the skill originally being called 'crouch'?

Last edited by LanceDH; 09/10/20 01:18 PM.