Another stream, another list

Clicking to melee attack a target in combat makes me path past another enemy first. While still walking, it enters the other unit's range, and gets hit with an attack of opportunity (entering melee range, not leaving).
In addition, the movement was interrupted before reaching the target, yet the cost of the action is still used up. It should either refund the action, or not use the requirements until the actual action takes place

When trying to path around a target to get behind it, the suggested pathing can suggest movement that would trigger an attack of opportunity, even when a safe path is also possible.

The Mind Flayer Pod on the ship showing the cutscene of a dazed women inside (that can be turned into a mind flayer), is empty outside the cutscene

Tiefling (and Mephistopheles Tiefling) tags show twice on the character sheet

Weight limit isn't well explained. On the timestamp I'm wondering why having 50/40 weight isn't affecting me. I google the 5e rules, but they don't seem related. Later on I find out that you get over-encumbered at 2x you limit, but this isn't explained.

The action log doesn't (always) scroll to the latest action. This could be by design. Regardless, a button to jump to the very bottom of the log would be appreciated.

The level up 'menu' needs to have a lot more information presented to the player. Essentially their character sheet and in some cases spell info.
Example of reasons:
Eldritch Invocation 'Agonizing Blast' mentions it will adds your charisma modifier as damage, but the info on the left only shows your actual charisma. If you're not knowledgable with DnD, you might now know 17 = +3.
Eldritch Invocation 'Armour of Shadows' allows you to cast Mage Armor, but doesn't show what that spell does, not helpful for people new to DnD.
Eldritch Invocation 'Devil's Sight' gives a form of dark vision. I have dark vision as a Tiefling. I remember that, some might not, but even then I don't know if this invocation is a better version of what I already have.
Eldritch Invocation 'Beguiling Influence' gives proficiency with deception and persuasion. I think already have proficiency with one of those because of the backstory, but I can't check to be sure

When equiping an item from a loot window, it doesn't always equip the item. Equipping a longbow, but still has goblin bow equipped

Encountering the devil for the first time in camp, my friend tried to use the 'attack' option twice. On both occasions it skips the conversation to either the second part or the end with no combat.

Companion jump actions such as the Imp's fly and the Giant Spider's jump use a blue bonus action icon, despite either using speed or an actual action. This could simply be because these spells don't have a custom icon yet. Spider Imp

At some point characters took damage from an unknown source. The action log indicated the damage, but no source. Only looking at it after the fact did I realize it was probably a trap that I failed the perception check for.
The damage roll tooltip was also void of any information. To help avoid confusion, maybe it could indicate it came from an unseen force or location, as this would look less like a bug or incomplete.

Since companions can't climb up walls/ladders like humanoids can, they will instead path another way around. This can cause the companion to run into enemies and get into combat on their own.

Actually not sure what happened here. At first I thought this was one of the cases where a projectile wouldn't follow the preview path and hit the terrain (that can happen regardless, it's an issue).
Looking back at it, the concentration gets broken for I assume a Hunter's Mark that was still going on a goblin that fled. But I have no clue what happened with the Ensnaring Strike that was shot. According to my friend my character was in the ground on his screen (I'm the host)

Possibly not a bug, but more a lack of feedback or just an unusual situation. I tried to web an Etterling standing on a web bridge. Nothing happened. I assume because it's immune to it, but I expected at least a message that it had no effect.

At some point during combat, my Giant Spider companion got stuck going in and out of combat over and over. This was fixed by having another character shove the spider.

In the Phase Spider cave, it's possible to send jump, or fly an imp, down into the deep pit, resulting in death. Haven't tested, but a character jumping down might possibly not be revived due to the distance.

Ground fire still there after a long time (almost an hour), even though the tooltip says it should only have been there for a total of 12 turns (that number never went down) This fire is created at this moment

At some point I jump onto a higher ledge and take 39 damage, presumably fall damage?

I give my friend 2 thieve's tools. He tried opening a chest once, fails, and both tool are used.

Destroying the chest with Highcliff's Blueprints, caused the blueprints to fly halfway into a wall, causing it to be unreachable to read or pick up. This was fixed by throwing the item somewhere else.

Friend knocked an enemy off the roof of a building using Eldritch Blast, but it didn't take any fall damage

This is heavy into desync territory. My friend leaves the game and I try to finish combat solo, but am unable to end the turn. Note how there's no imp companion portrait above the warlock (halfling) portrait in the bottom left. Saving and reloading fixed the imp portrait and let me end its turn.

Entering camp, we are instantly attacked by Scratch. It's unsure if this is intentional or if something messed up as it just happens with no lead up.

Pathing off a roof can show you a line straight down as to indicate walking off it. This has no indication that doing so might be hazardous and potentially deadly. Making the line red, much like walking over a fire surface, might be a good idea.

Not so much issues as suggestions or notes.

Bonus health isn't shown on the portraits in the bottom left. Probably by design due to limited space, but would be valuable information in the overview.

When playing multiplayer, when two player characters are in a dialog with each other, it isn't always clear which player is currently picking, especially when you can cast a vote for the other player's options. This might be because of the dynamic cinematic currently not always showing the right character and the right time.