I'm using Vulkan and having the same terrain issues other's have reported, but I will actually get stuck. If I am in a cave, house, or underground (enclosed I guess) and try to view various parts of that area I seem to "fall" into a hole and the only way I can get out is to restart the game from my last save.

Also, in the underground area of the Blighted Village, the characters either become completely invisible or only portions of their armor are visible. I have moved the camera angle to see if it helps, but then all of the walls disappear. I've tried to exit and re-enter to see if the issue is consistent or just rendering poorly at the moment, but it is consistent.

Leaving and going to camp seems to be a common issue. I've not had the issue of going to camp, but when there is any story-telling scenes (Raphael for example) at camp, I find it a chore to leave. I've tried going to each character I wish to bring, but they are already in my group so I get no dialogue to accept them and leave. The only way I have found that works is to choose each character and individually have them leave camp for us to group. Even then, the map icon still indicates I will be going to camp to end the day while I am at camp, but it does allow me to leave.

And I agree with the "fog" comments above. I used it once in an enclosed area and it worked well for some npc's at a distance and they were only able to attack when they closed in. Another time I used it in a cave on a ranged npc and it did nothing. Maybe this is working as intended (small spaces only)? Also, the character that used fog the first time seemed to have a debuff even after leaving the foggy area. There were no other effects nearby that I could find.