https://www.reddit.com/r/BaldursGate3/comments/q7cohp/blurry_when_running_vulcan/

Hopefully this may help, to quote the link:
Find your bg3.exe file -> properties -> Compatibility -> Change high DPI settings -> Override high DPI Scaling behaviour, performed by: "Application"