OH!!! Grymforge does NOT like Party of 6. I had Party of 6. Went to the boat. Got to Grymforge. Lae'zel and Wyll were suddenly ghosts. They had no HP, could not move, were grouped together and still at the docks in Decrepit Village. They did not go with the rest of the party to Grymforge. I tried several times. Same result. I tried Fast Travel back to the beach. They were there but not there. I tried to select them, and it let me, but they did not appear on the screen at all. I tried to fast travel as them, and they'd go to the location I had them fast travel to, even to camp, but they were invisible and still no HP and they couldn't move or anything. I tried linking them to the rest of the party while in the same exact spot as them. They stayed in that spot no matter where I went.

The only fix: Before you go onto the boat, pick two characters and ungroup them. Leave them on the beach and only take a party of 4 to Grymforge. Don't ask them to leave the party. Just ungroup them and leave them at Decrepit Village BEFORE you access the boat. Then, when you get to Grymforge with your party of 4, make sure you access the Waypoint (I think it's automatic anyway). Then fast travel back to the beach, regroup them, and fast travel back to Grymforge as one whole party. As long as you ungrouped 2 characters before going to Grymforge, you can regroup them after you go through the cutscenes and you should be fine from there.