I'll re post this here, checking almost every day for a damn fix to no avail. Maybe something here will work for you...

For me the saves stop working as soon as you crash on the beach in the beginning, they seem to work before that, from a new game i can load just fine as long as I dont close out the program or go to the main menu, as soon as i do that the loads stop working...when I reported the problem I tried every solution they could think of and i still cant get it working. Its been happening since the barbarian patch. This is what they recommend.

On Tue, 12 Apr at 3:10 AM , BG3 Support <supportbg3@larian.com> wrote:
Are you shutting down all non-essential programs (especially anti-virus) before starting the game? Firewalls can cause conflicts (generally on startup or loading screens) and overlays from graphics tweaking/monitoring programs or chat programs can also cause issues.

Try dropping the graphics settings, lower the resolution and switch to Windowed display mode, to see if that makes a difference.

If you start a new game, can you make a manual save and load it properly? Moving a bit from the initial character position can trigger an auto save, which might overwrite one from your current playthrough.
If that works, can you then load the latest save from your current playthrough?

Try browsing to the 'C:\Users\<UserName>\AppData\Local\Larian Studios\Baldur's Gate 3\LevelCache' folder and delete the contents. A corrupt file there can cause problems, usually when saving or loading. The easiest way to get there would be to copy the line below into the location bar in Explorer and hit Enter.
%LocalAppData%\Larian Studios\Baldur's Gate 3\LevelCache

In the launcher, try switching between DirectX 11 and Vulkan, as applicable, to see if that makes a difference.

Try exiting out of the Steam client and starting the game directly from the '..\SteamApps\common\Baldurs Gate 3\bin' folder, by right clicking the executable (bg3.exe for Vulkan, or bg3_dx11.exe) and running as administrator.
Try right clicking the executable, select Properties, switch to the Compatibility tab and check off the 'Override high DPI scaling behavior' option (set it to Application), run as administrator and disable fullscreen optimization, and maybe set a Win 7 or 8 compatibility mode. In Windows 7, check off the option to 'Disable display scaling on high DPI settings', disable desktop composition and run as administrator.


If that doesn't help, please reply with your latest save (or a Dropbox or Google drive link, etc).
In Explorer you can zip a file or folder by right clicking on it/them and selecting 'Send To | Compressed (zipped) Folder'.
Each save is a folder in the 'C:\Users\<UserName>\AppData\Local\Larian Studios\Baldur's Gate 3\PlayerProfiles\<ProfileName>\Savegames\Story' folder. The fastest way to get there would probably be to copy the line below into the location bar in Explorer and hit Enter, then browse down from there.
%LocalAppData%\Larian Studios\Baldur's Gate 3\PlayerProfiles

Please also include a dxdiag report (WinKey-R, type in dxdiag and hit enter, then when it finishes loading click on the 'Save All Information...' button and save the report somewhere handy).