Larian Banner
Previous Thread
Next Thread
Print Thread
Game becoming unplayable due to lag! #666987
02/05/20 02:55 PM
02/05/20 02:55 PM
Joined: Jan 2005
Posts: 288
L
Lostsheep Offline OP
enthusiast
Lostsheep  Offline OP
enthusiast
L

Joined: Jan 2005
Posts: 288
The lag gets worse during the day, in the morning I might play for 20 minutes before the game lags to the poin os lock-up. In the afternoon maybe 10 minutes and in the evening 5 minutes! I started a new game last night and it even locked up on the prison ship prior to Fort Joy.

I have the graphics turned down to medium and shadows disabled. My system specs are as folows.

OS Name Microsoft Windows 10 Home
Version 10.0.18362 Build 18362
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-IU5A76J
System Manufacturer Dell Inc.
System Model G5 5587
System Type x64-based PC
System SKU 0825
Processor Intel(R) Core(TM) i5-8300H CPU @ 2.30GHz, 2304 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date Dell Inc. 1.12.2, 24/12/2019
SMBIOS Version 3.1
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Dell Inc.
BaseBoard Product 0MJGJT
BaseBoard Version A00
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume4
Locale United Kingdom
Hardware Abstraction Layer Version = "10.0.18362.752"
Username DESKTOP-IU5A76J\User
Time Zone GMT Summer Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.80 GB
Available Physical Memory 4.06 GB
Total Virtual Memory 13.5 GB
Available Virtual Memory 6.31 GB
Page File Space 5.75 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualisation-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Please can someone help, I love the game but I can't play it like this!

Thanks,
LS.

Re: Game becoming unplayable due to lag! [Re: Lostsheep] #667001
03/05/20 08:01 AM
03/05/20 08:01 AM
Joined: Mar 2003
Posts: 27,533
Canada
Raze Offline

Larian Studios
Raze  Offline

Larian Studios

Joined: Mar 2003
Posts: 27,533
Canada

Have you tried other, similarly demanding DirectX 11 games recently?

Check exhaust fans, etc, to make sure they are clean and working properly. The playtime decreasing with the time the computer has been running is consistent with heat issues. If you quit and restart immediately, do you get another X minutes of playtime, or is it shorter?

Try lowering the graphics settings and resolution, and switching to Windowed or Fake Fullscreen display mode, to see if that will make a difference.

Re: Game becoming unplayable due to lag! [Re: Lostsheep] #667028
04/05/20 09:52 AM
04/05/20 09:52 AM
Joined: Jan 2005
Posts: 288
L
Lostsheep Offline OP
enthusiast
Lostsheep  Offline OP
enthusiast
L

Joined: Jan 2005
Posts: 288
Thanks Raze, I've done all the above and though graphics have taken a hit I can play much longer before lag kicks in. One more question please, when lockup happens task manager shows CPU usage at 95% and GPU at 99! Is this normal and if not, what could be causing it.

Sorry that's two! grin

Thanks,
LS.

Re: Game becoming unplayable due to lag! [Re: Lostsheep] #667065
05/05/20 04:29 AM
05/05/20 04:29 AM
Joined: Mar 2003
Posts: 27,533
Canada
Raze Offline

Larian Studios
Raze  Offline

Larian Studios

Joined: Mar 2003
Posts: 27,533
Canada

The lockup is not normal. It is normal that the CPU/GPU usage can spike close to 100% but that is usually only temporary, in areas with a lot of scripts being triggered, or in combat with explosions going off, etc. Heat issues can cause the GPU to be maxed, if it clocks itself down to avoid heat damage.

If you do not have a laptop cooler, try placing a book, or something, under each corner, so there is as much surfaced open as possible, while remaining stable, then point a fan at the laptop so there is airflow under the laptop and across the keyboard.


If it isn't heat related:

Try doing a clean boot and then test the game. Click Start, or hit WinKey-R, type in msconfig and hit enter; in the General tab, click Selective Startup, uncheck Load startup items (if required) and leave Load system services and Use original boot configuration options checked. Next, click on the Services tab, check the box to Hide all Microsoft services, then click the Disable All button (maybe make a note of which are currently enabled/disabled), then click OK and reboot the computer.
Run msconfig again to switch back to the normal boot configuration.

Try resetting your graphics driver's 3D settings to default (right click an open area of the desktop to start the nvidia Control Panel).

Make sure the Virtual Memory setting in Windows is set to automatic / system managed, rather than being disabled or set to a fixed size (to check or change virtual memory settings in Win 10, see here), and you have enough free hard drive space. Unless you reboot before playing, memory usage can tend to increase during the day, and might account for performance dropping faster the longer the system has been on (though less likely to cause CPU/GPU usage spikes, at least directly; the way the game handles low memory might, theoretically).

Does disk activity increase beyond normal leading up to the freezing?


One person with performance issues with D:OS EE on an i7 CPU fixed it by setting the game not to use the first 2 CPU cores, since Windows was running everything else on them, as well. Another was getting stuttering, and fixed it by switching the game to use only one core, applying, then switching it back to all 4 cores.
To try this (though these issues were not related to the time the system was running), start the game, then start the Task Manager (Ctrl-Shift-Esc or right click an open area of the Task Bar), switch to the Processes tab, right click on EoCapp.exe and select 'Set Affinity...'. After that, try unselecting Core 0 and 1, apply and test the game, or unselect most of the cores, apply and select all of them again.

Also in the Task Manager Processes tab, try right clicking EoCApp.exe and under Set Priority, select High or Realtime.


Nvidia may have newer graphics drivers, with more up to date fixes that you could try. If you already are, Dell's drivers should be better optimised for that system, and be more stable, so you could try reverting to those. See here or here, for example, for guides on how to cleanly reinstall/update graphics drivers.

Re: Game becoming unplayable due to lag! [Re: Lostsheep] #667084
06/05/20 08:19 AM
06/05/20 08:19 AM
Joined: Jan 2005
Posts: 288
L
Lostsheep Offline OP
enthusiast
Lostsheep  Offline OP
enthusiast
L

Joined: Jan 2005
Posts: 288
That's great Raze, I'll get my son on that when we next Skype.


Powered by UBB.threads™ PHP Forum Software 7.6.2